• z

    Zach Zeid

    1 year ago
    I'm having some problems with fleetctl not recognizing my switches on the command line?
    fleetctl config set --context default
    NAME:
       fleetctl config set - Set config options
    
    USAGE:
       fleetctl config set [options]
    
    OPTIONS:
       --config value      Path to the fleetctl config file (default: "/Users/zzeid/.fleet/config") [$CONFIG]
       --context value     Name of fleetctl config context to use (default: "default") [$CONTEXT]
       --address value     Address of the Fleet server [$ADDRESS]
       --email value       Email to use when connecting to the Fleet server [$EMAIL]
       --token value       Fleet API token [$TOKEN]
       --tls-skip-verify   Skip TLS certificate validation (default: false) [$INSECURE]
       --rootca value      Specify RootCA chain used to communicate with fleet [$ROOTCA]
       --url-prefix value  Specify URL Prefix to use with Fleet server (copy from server configuration) [$URL_PREFIX]
       --help, -h          show help (default: false)
  • zwass

    zwass

    1 year ago
    What are you trying to do? Might just be missing a flag.
  • z

    Zach Zeid

    1 year ago
    I'm trying to set the context pointing to my api key. because I cannot
    fleetctl login
    . it. just. asks me for my un/pw
  • which we dont hhave due to SSO
  • zwass

    zwass

    1 year ago
    Try
    fleetctl config set --token <paste here>
  • z

    Zach Zeid

    1 year ago
    Set the token config key to "foobarbaz" in the "default" context
    fleetctl login
    Log in using the standard Fleet credentials.
    Email: email@address
    Password:
    Login failed: login received status 401 Authentication failed: Authentication failed
  • zwass

    zwass

    1 year ago
    Ah after you set the token you don't need to do a login
  • z

    Zach Zeid

    1 year ago
    ayayay that'll solve it, thanks