Channels
  • t

    Tor Houghton

    4 months ago
    I think I may have found a bug (in 4.9.0). I have a hostname called "vr.home.bogus.net" which appears in the list of hosts, but I am not able to do a specific queries for this host (when I type in the hostname or indeed the fqdn, it does not appear in the list (though the UI will suggest other hosts)).
  • Tomas Touceda

    Tomas Touceda

    4 months ago
    hi there! sorry hear you're having issues. Is the bug that you cannot seem to select this host to do a live query against? or that when you do, it fails?
  • t

    Tor Houghton

    4 months ago
    it doesn't show up in the suggestions when you search 🙂
    Queries v Hosts
  • Tomas Touceda

    Tomas Touceda

    4 months ago
    the tool we use to search underneath in some cases has a lower limit of 3 chars, does it work if you search for
    vr.h
    ?
  • t

    Tor Houghton

    4 months ago
    That's the thing; nothing shows up at all until I type "vr.hom" -- and then the "vr" host is left out of the results 😉
  • Tomas Touceda

    Tomas Touceda

    4 months ago
    will look into it and keep you posted, thank you for mentioning the issue!
    I can't reproduce quickly, gonna create an issue shortly. if you search for the exact host, does it appear then? sometimes if you search for things that match many hosts, those might "kick off" the host you are expecting from the list
  • t

    Tor Houghton

    4 months ago
    Nope!
  • Tomas Touceda

    Tomas Touceda

    4 months ago
    is this host in a team? what role is the user you are testing this with?
  • t

    Tor Houghton

    4 months ago
    If I have time later I can try to recreate with a different (short) host name. I am just using the default "admin" user. And it is not part of any team.
    I have a few three-letter hosts that show up fine, btw.
  • Tomas Touceda

    Tomas Touceda

    4 months ago
  • Noah Talerman

    Noah Talerman

    4 months ago
    @Tor Houghton if you’re able, can you please send a screenshot of the request and response for of the
    /targets
    API route when the host isn’t showing up? You can find this in the “Network” tab in your browsers dev tools. This will provide more information for debugging. Thank you 😃
  • t

    Tor Houghton

    4 months ago
    This is the request payload (raw): {"query":"vr.","query_id":158,"selected":{"hosts":[],"labels":[],"teams":[]}}
    This is the response (raw): { "targets": { "hosts": [], "labels": [ { "created_at": "2021-11-22T08🔟29Z", "updated_at": "2021-11-22T08🔟29Z", "id": 6, "name": "All Hosts", "description": "All hosts which have enrolled in Fleet", "query": "select 1;", "platform": "", "label_type": "builtin", "label_membership_type": "dynamic", "host_count": 32, "display_text": "All Hosts", "count": 32 } ], "teams": [] }, "targets_count": 0, "targets_online": 0, "targets_offline": 0, "targets_missing_in_action": 0 }
    When I enter "vr.hom": {"query":"vr.hom","query_id":158,"selected":{"hosts":[],"labels":[],"teams":[]}}
    I get a response that contains lots of hosts (400-odd lines of JSON).
    Does this help?
    (I am on 4.10 now, by the way.)
  • Noah Talerman

    Noah Talerman

    4 months ago
    Yes, thank you! I added this information to the bug report issue here: https://github.com/fleetdm/fleet/issues/3979
    I get a response that contains lots of hosts (400-odd lines of JSON). This response does not include the host you’re looking for, correct?
  • t

    Tor Houghton

    4 months ago
    That's correct. And I added another two-character named host just to make sure and neither one show up.
    It's quite strange though. If I search for "so.hom", that host shows up in the list of results, but if I search "vr.hom", it doesn't -- but the so.hom host does:
  • Noah Talerman

    Noah Talerman

    4 months ago
    Yeah that’s unexpected. Sorry you’re still experiencing this issue. The Fleet team will likely resolve this issue in the upcoming release of Fleet. Also, thanks for the additional info. Please feel free to add any more screenshots/comments in the following issue: https://github.com/fleetdm/fleet/issues/3979
  • t

    Tor Houghton

    4 months ago
    Hey, don't be sorry -- I'm glad you guys want my input 🙂
    (And hopefully you're able to recreate it 🙂